Seasons change

Winter stops, sometimes quickly, sometimes it hangs on. This year it left quickly with warm wet winds stripping the snow base from the lower mountain and despite Turoa declaring Snovember we didn’t head up there at all through October, November. 

This is from the last big dump in early October, snow fell as far down as the house, and for the first time I was there for that. This is on the mountain road on the way up to Turoa. 


So, we now turn our minds to the warmer months, bike rides, mountain walks, river swimming, golf, BBQ, whatever. 

So, a long warm Summer is requested, and time with friends and family – hope you all have the same.

Advertisements

And the Spa is complete (almost)

This year has been the year (so far) of getting the deck built and the spa put into place and then setting it up to work correctly and be easy to use. So until last weekend we had much of this sorted, but not the last part.

Over the last weeks the electrician and gas guy/pumber  (it’s a gas powered unit remember) worked together; result, a permanent power source to the spa was installed.

PowerSwitch

 

 

 

The gas line put into place and made easy to access alongside the deck, at the bottom of the back porch stairs.

GasBottle

 

 

 

 

Then the heating unit was refitted, all electrical connections tested and certified.

HeaterUnit

 

 

 

Finally, all was in place, so when we arrived last weekend and set it all up we were very expectant of being able to set it up, get it going and enjoy a spa on Saturday evening. We flicked the main switch to on and everything burst into life, the airjets swirled, the digital readout lit up and the temperature started going up – very slowly, very very slowly.

Then it stopped. And would go no further.

A quick call to the gas guy (2.30 saturday afternoon) and remotely he toook me through a range of remedial options, bleed the gas line, check the fitting here / there etc. It seemed to work, then again we topped out at about 17 degrees, not warm at all. Saturday night spa was off. Sunday morning the gas guy rang, “I’m coming down” he said, be there about 11.30am.

He arrived, did his own testing, we checked all electrical fittings as well, strange – no power at the igniter switch – stood there scratching our heads…….then light bulb moment.

The airjets were running, not the water jets, and if there was no water running through the igniter switch, there was no ignition – the unit requires pressure there to get the spark going, so a quick push on the button on the top of the spa, air jets off, water jets on, ignition, flame = heat.

So, for all who come after us the set up is simple. If the spa is empty, fill from the hose reel fitted to the back wall of the house, fill to above the water jet nozzles, but below the mosiac line.

OnSwitch1

 

 

 

 

 

Attach gas bottle, turn on power, turn on main switch (the one of the right – the red one has to be in the on position as well) listen for the water jets to be running inside the pool and then the ignition kicks in and magic happens.

And, thanks to the gas guy / plumber we also have a drainage process that isn’t manual labout and involves buckets. The drain plug sits at the base of the spa, connect the hose and run the hose to the drain, then open the panel and reach inside, turn the red handle and the spa empties.

The gas guy / plumber?

Mike from Tuamaranui Plumbing, can’t say thank you, loud enough for all his efforts, he and team there are very, very good indeed. Use them if you can.